FIXED: The Great Work DOA (won't start)

  • 9 Replies
  • 5175 Views
FIXED: The Great Work DOA (won't start)
« on: February 06, 2013, 10:20:39 »
Every time I try to run The Great Work, I get nothing. No processes even appear to start. No flash, no infinitesimally transient window, not a whiff. Any ideas?

Windows 7 64bit, NVIDIA GeForce 310M, DoctorGL tells me I have the capabilities referenced in another thread on this forum.

Thanks in advance!
« Last Edit: February 07, 2013, 02:11:26 by mrunless »

*

Offline J

  • Information leaking
  • 242
  • 12
  • I have a chicken on my head.
    • View Profile
    • Greywool
Re: The Great Work DOA (won't start)
« Reply #1 on: February 06, 2013, 16:27:19 »
Windows 7 64bit, NVidia GeForce GTS 250 'ere, works all fine and dandy.

Could it be a problem with access rights? Where'd you install it? Normal installation or portable? 1.0.0 or 1.0.1?
"flipping around like an idiot" -- Paula

Re: The Great Work DOA (won't start)
« Reply #2 on: February 07, 2013, 00:57:20 »
I tried both methods of installation, into different directories. I also ran as administrator and not.

Update FIXED: The Great Work DOA (won't start)
« Reply #3 on: February 07, 2013, 02:28:45 »
After polling the Windows Event Log, I noticed that the culprit was the OpenAL32.dll packaged with Great Works. I ran OAInst.exe (from http://connect.creativelabs.com/developer/Wiki/OpenAL%20Installer%20for%20Windows.aspx) to make sure the version I have in windows/system32 is up to date, then I copied OpenAL32.dll from windows/system32 to the Great Works install folder.

Just posting here for reference in case anyone else experiences the same issue as I.

Cheers!

*

Offline LPChip

  • You can only truly help other people by allowing them to fail.
  • 3429
  • 125
  • Excel at the thing you're the best at!
    • View Profile
    • LPChip Interactive
Re: FIXED: The Great Work DOA (won't start)
« Reply #4 on: February 07, 2013, 02:31:46 »
Thanks for sharing your solution. I'm sure it may help someone else too. :)

Have a +rep for posting it. :)
on the left, above my avatar.

MODPlug Central Forum
"If I tried to kill you, I'd end up with a big fat hole through my laptop." - Chironex

*

Offline Nifflas

  • 1532
  • 59
    • View Profile
Re: FIXED: The Great Work DOA (won't start)
« Reply #5 on: February 07, 2013, 03:58:06 »
That's super interesting! I wonder what's wrong with the version that comes with the game.

Re: FIXED: The Great Work DOA (won't start)
« Reply #6 on: February 09, 2013, 02:54:22 »
It's possible that it's a slightly older version that's incompatible with some hardware on my machine; this is the second time I've encountered an issue that involved OpenAL32.dll.

The version packaged with Great Work 1.0.1 doesn't show any version info in Properties, but it differs in size (Great Works version of the .dll is 273 Kb, modified on 11/17/12, whereas the one updated by OAInst.exe is 120 Kb, modified on 2/5/13, file version 6.14.357.24)


*

Offline Nifflas

  • 1532
  • 59
    • View Profile
Re: FIXED: The Great Work DOA (won't start)
« Reply #7 on: February 09, 2013, 11:40:54 »
yeah, the one in TGW is custom compiled and modified to accept alsoft.conf to sit in the application folder. By default OpenAL it only reads alsoft.conf if it's in the roaming application data folder and is shared between all applications that uses OpenAL, which is insane because my games sounds best with cubic interpolation but another game may need zero-order interpolation for the retro feel. It's beyond me why this decision was made.

*

Offline Mathias

  • 32
  • 5
    • View Profile
Re: FIXED: The Great Work DOA (won't start)
« Reply #8 on: February 09, 2013, 23:15:08 »
mrunless, what did the eventlog say about OpenAL32.dll? We don't use Creative's implementation since it's really bad, but rather OpenAL-Soft.

Thanks!

*

Offline Comhon

  • 284
  • 12
    • View Profile
Re: FIXED: The Great Work DOA (won't start)
« Reply #9 on: February 24, 2013, 05:26:07 »
It doesn't work for me, the window just blink for a whlie and then it closes