GLIB_2.14 Not Found (linux)

  • 1 Replies
  • 6387 Views
*

Offline Isel

  • 1
  • 0
    • View Profile
GLIB_2.14 Not Found (linux)
« on: December 20, 2011, 14:47:34 »
Hello everyone! I recently bought the game for linux in the Humble Indie Bundle. This isn't a real issue because I can play the 32-bit version just fine, but when I try to launch the 64-bit version I get the following error:

Code: [Select]
./NightSkyHD_64: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by /home/miguel/NightSky/lib64/libalut.so.0)
./NightSkyHD_64: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by /home/miguel/NightSky/lib64/libGLU.so.1)
./NightSkyHD_64: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by /home/miguel/NightSky/lib64/libogg.so.0)
./NightSkyHD_64: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by /home/miguel/NightSky/lib64/libz.so.1)

I'm using Ubuntu 11.10 64-bit, and, as I can see, the latest version of libc6 available for ubuntu is the libc6 2.13-20ubuntu5.

Thank you for your great game.

*

Offline simon

  • 7
  • 0
    • View Profile
Re: GLIB_2.14 Not Found (linux)
« Reply #1 on: December 20, 2011, 15:16:01 »
You could install libalut,  libogg and libz using the package manager and rename/remove the lib64 folder. The main executable is compiled against an older version of glibc for compatibility reason, it's just the libraries that cause problems for you.